Author Topic: Flickering Signs.  (Read 178 times)

Grooveski

  • Sr. Member
  • ****
  • Posts: 389
    • View Profile
Flickering Signs.
« on: August 05, 2017, 02:09:15 PM »
Signs flicker if they're in front of another model(walls, bridges, buildings...).   :(
The same happens on building models where perhaps the windows have been added as an additional poly over the top of a solid wall. (on old GPL tracks and the likes)

They're worse at a distance and flicker less as you get closer.
If you use a free roam camera you can watch the back polys peeking through more and more as you pull back.



Things I've tried:
Removing the bottom polys of the signs so they don't interfere with the ground - No change.
Checked the sign models for duplicate polys - There weren't any.
Checked sign and wall models didn't overlap anywhere - They didn't.
Reset the white and colour balance of the sign skins - No change.
Sectioned up the sign models into many model layers/objects instead of all on one - No change.
Made the signs thicker (from 10mm thick to 50mm) - worked for some of them but not all - would be fairer to say it lessened the flickering rather than fixing it.
Deleted the back polys and built the signs right into the building/wall models - worked but not always practical, the signs here are supposed to be a different size from the tyrewall.

A possible clue worth mentioning is that it doesn't appear to happen if the back polys are wearing an alpha'd tga.  ???  In the picture above the second row of signs at the left are up against a wire fence - similar model geometry, exact same sign skin and no flickering or peeking through.  It's the same at turn 3 where the sign is against the fence rather than a wall.
« Last Edit: August 05, 2017, 02:20:17 PM by Grooveski »

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 2096
    • View Profile
Re: Flickering Signs.
« Reply #1 on: August 05, 2017, 10:41:38 PM »

The usual solution is to add a little space between the wall and the sign.

Grooveski

  • Sr. Member
  • ****
  • Posts: 389
    • View Profile
Re: Flickering Signs.
« Reply #2 on: August 05, 2017, 11:22:08 PM »
Increased the gap at the same time as I thickened the signs.
Had made them with a gap in the first place but took it up from a 10mm thick sign with a 20mm gap to a 50mm thick sign with a 40mm gap.



The picture sequence at the hairpin was taken after the signs had been thickened.

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 2096
    • View Profile
Re: Flickering Signs.
« Reply #3 on: August 07, 2017, 10:09:50 AM »
Are both texture opaque, with no alpha channel?
If they are, then unfortunately at the moment there isn't much that can be done, except further increasing the distance between the sign and the wall.

For the future, it may be a good idea to add a new exporting object flag to make sure that the sign is drawn after the wall.
« Last Edit: August 07, 2017, 10:11:46 AM by PiBoSo »

Grooveski

  • Sr. Member
  • ****
  • Posts: 389
    • View Profile
Re: Flickering Signs.
« Reply #4 on: August 07, 2017, 12:16:50 PM »
Yes, both opaque in all the problems bits on this track.
...and on  the other tracks that suffer from it I think - seemes to always be signs in front of buildings and walls, never fences or trellis gantrys.

I shall look into export order.   ;)
...and it crossed my mind that alphas could be added to the building and wall textures.  Most have unused/unseen areas in their UV maps and the even the ones that don't could have a single just-off-white alpha pixel added. 

Thanks for looking into it.   :)