Author Topic: MaxHUD plugin  (Read 90965 times)

Nicotine

  • Full Member
  • ***
  • Posts: 128
  • Nicotine
    • View Profile
Re: MaxHUD plugin
« Reply #720 on: June 26, 2017, 11:37:05 AM »
Thank You  ;D
GP-Bikes Indonesia

uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #721 on: July 04, 2017, 12:41:25 PM »
Hey Max,

In perusing the many videos and screen shots I noticed the Speed Readout was off set to the right so it wasn't in the middle of the screen. At the time I didn't make a note of what image it was so I can not include a screen shot.

Can the speed readout be moved to the side? I ask because it obscures the road up ahead on the Ulster GP Course and I can see far enough ahead. It doesn't seem to be an issue on race tracks.

HornetMaX

  • Hero Member
  • *****
  • Posts: 5780
    • View Profile
Re: MaxHUD plugin
« Reply #722 on: July 04, 2017, 12:43:35 PM »
Hey Max,

In perusing the many videos and screen shots I noticed the Speed Readout was off set to the right so it wasn't in the middle of the screen. At the time I didn't make a note of what image it was so I can not include a screen shot.

Can the speed readout be moved to the side? I ask because it obscures the road up ahead on the Ulster GP Course and I can see far enough ahead. It doesn't seem to be an issue on race tracks.

You can move it like all the other widgets (press caps lock to show the menu, then right click on the widget and drag it around).

uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #723 on: July 04, 2017, 05:07:13 PM »
Tried the left mouse button but didn't try the right. Thank you.

speedfr

  • Full Member
  • ***
  • Posts: 208
  • Partir, c'est pourrir un pneu !
    • View Profile
Re: MaxHUD plugin
« Reply #724 on: November 23, 2017, 01:06:59 AM »
Thanks a lot !
Great idea  :-*

Works great with beta 12b.
Missing Gp500 (Microprose)

Testing EDTracker Pro on YT

i7-4790K/16Go/GTX1070/1440p/Full WC

franking

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: MaxHUD plugin
« Reply #725 on: January 17, 2018, 03:16:10 PM »
Amazing work MAX!
Widgets are really useful and practical. Especially the rumble helps a lot with feeling the dynamic of bikes.
But one small problem, seems to use the plugin on 12b with my computer will get some frame stutters and lag.
It's like a very short lag between about every second.
Looking forward to your new version or some solutions.
Again nice work and thanks a lot MAX.
« Last Edit: January 17, 2018, 04:01:39 PM by franking »

uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #726 on: January 18, 2018, 02:38:44 AM »
Amazing work MAX!
Widgets are really useful and practical. Especially the rumble helps a lot with feeling the dynamic of bikes.
But one small problem, seems to use the plugin on 12b with my computer will get some frame stutters and lag.
It's like a very short lag between about every second.
Looking forward to your new version or some solutions.
Again nice work and thanks a lot MAX.

What graphics adapter are you using? I used to have a GTX1070 and it stuttered like mad after 10 to 15 minutes of riding. I switched to an AMD WX7100 [I do CAD design work] and my issues went away. I never tried unloading MaxHUD to see if that was causing the problem.

HornetMaX

  • Hero Member
  • *****
  • Posts: 5780
    • View Profile
Re: MaxHUD plugin
« Reply #727 on: January 18, 2018, 07:24:27 AM »
Amazing work MAX!
Widgets are really useful and practical. Especially the rumble helps a lot with feeling the dynamic of bikes.
But one small problem, seems to use the plugin on 12b with my computer will get some frame stutters and lag.
It's like a very short lag between about every second.
Looking forward to your new version or some solutions.
Again nice work and thanks a lot MAX.
Strange. I had 2-3 reports like this in the past 3 years but every time it was due to something else.
The plugin code hasn't been touched for quite a while (except the necessary changes to cope with GPB/MXB/KRP/WRS new versions).

What graphics adapter are you using? I used to have a GTX1070 and it stuttered like mad after 10 to 15 minutes of riding. I switched to an AMD WX7100 [I do CAD design work] and my issues went away. I never tried unloading MaxHUD to see if that was causing the problem.
Weird. Had a 970 for a while and got a 1080 right now, never noticed anything similar.
Also, I guess we have a fair share of people with nvidia cards and we haven't heard something like this.

uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #728 on: January 18, 2018, 11:55:58 AM »

What graphics adapter are you using? I used to have a GTX1070 and it stuttered like mad after 10 to 15 minutes of riding. I switched to an AMD WX7100 [I do CAD design work] and my issues went away. I never tried unloading MaxHUD to see if that was causing the problem.
Weird. Had a 970 for a while and got a 1080 right now, never noticed anything similar.
Also, I guess we have a fair share of people with nvidia cards and we haven't heard something like this.

I tend to think the issue I had with stuttering was driver related and did not have anything to do with MaxHUD. The initial drivers I installed were stable and stutter free. Newer drivers introduced stuttering. I replaced the graphics adapter because something kept reinstalling the worst performing drivers no matter what actions I took to avoid them. I decided to sell the GTX and go back to AMD's WX7100 [it may not be as fast as the 1070 but it is far more stable and works better with the CAD software I use].

HornetMaX

  • Hero Member
  • *****
  • Posts: 5780
    • View Profile
Re: MaxHUD plugin
« Reply #729 on: January 18, 2018, 12:08:19 PM »
I tend to think the issue I had with stuttering was driver related and did not have anything to do with MaxHUD. The initial drivers I installed were stable and stutter free. Newer drivers introduced stuttering. I replaced the graphics adapter because something kept reinstalling the worst performing drivers no matter what actions I took to avoid them. I decided to sell the GTX and go back to AMD's WX7100 [it may not be as fast as the 1070 but it is far more stable and works better with the CAD software I use].
Still weird though: PiBoSo games are openGL, nvidia drivers have been generally better/more stable in the past. To be more precise, in the past we had multiple cases of AMD screwing things up periodically for openGL. I know first hand, had a 4850, 2x4850, a 6850 and a 7950 before going green.

It could be though that AMD's WX have less issue as openGL is more of a priority for pros.

uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #730 on: January 18, 2018, 12:29:51 PM »

Still weird though: PiBoSo games are openGL, nvidia drivers have been generally better/more stable in the past. To be more precise, in the past we had multiple cases of AMD screwing things up periodically for openGL. I know first hand, had a 4850, 2x4850, a 6850 and a 7950 before going green.

It could be though that AMD's WX have less issue as openGL is more of a priority for pros.

I have always had much better results with Workstation level graphics adapters / drivers than I have with consumer / gaming oriented items, especially when it comes to applications that use OpenGL. I use the AMD WX7100 because it is less expensive than an NVidia Quadro K4000 adapter.

franking

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: MaxHUD plugin
« Reply #731 on: January 18, 2018, 02:43:19 PM »
Amazing work MAX!
Widgets are really useful and practical. Especially the rumble helps a lot with feeling the dynamic of bikes.
But one small problem, seems to use the plugin on 12b with my computer will get some frame stutters and lag.
It's like a very short lag between about every second.
Looking forward to your new version or some solutions.
Again nice work and thanks a lot MAX.
Strange. I had 2-3 reports like this in the past 3 years but every time it was due to something else.
The plugin code hasn't been touched for quite a while (except the necessary changes to cope with GPB/MXB/KRP/WRS new versions).
Yes, what's more strange is that this problem doesn't always happens.
Usually it won't happen when I just boot my computer and enter the game without doing many things.
I tried to find out what causes the problem but no conclusion yet.
But one thing is when the game start lagging, I tried removing the plugin and restart the game, it will become normal instantly.
Very strange problem...
« Last Edit: January 18, 2018, 03:48:10 PM by franking »

uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #732 on: January 18, 2018, 04:24:17 PM »
Amazing work MAX!
Widgets are really useful and practical. Especially the rumble helps a lot with feeling the dynamic of bikes.
But one small problem, seems to use the plugin on 12b with my computer will get some frame stutters and lag.
It's like a very short lag between about every second.
Looking forward to your new version or some solutions.
Again nice work and thanks a lot MAX.
Strange. I had 2-3 reports like this in the past 3 years but every time it was due to something else.
The plugin code hasn't been touched for quite a while (except the necessary changes to cope with GPB/MXB/KRP/WRS new versions).
Yes, what's more strange is that this problem doesn't always happens.
Usually it won't happen when I just boot my computer and enter the game without doing many things.
I tried to find out what causes the problem but no conclusion yet.
But one thing is when the game start lagging, I tried removing the plugin and restart the game, it will become normal instantly.
Very strange problem...

When I used the GTX I would reboot prior to starting GP-Bikes and everything would be fine for a period of time.

The driver supplied by the manufacturer of the card worked perfectly but whatever gremlin that inhabits my computer kept updating the driver. You can read about my travails here: http://forum.piboso.com/index.php?topic=5391.0

HornetMaX

  • Hero Member
  • *****
  • Posts: 5780
    • View Profile
Re: MaxHUD plugin
« Reply #733 on: January 19, 2018, 04:03:21 PM »
The driver supplied by the manufacturer of the card worked perfectly but whatever gremlin that inhabits my computer kept updating the driver.
Only way to make sure everything is done by the books for GPU drivers: use DDU (Display Driver Uninstall, free) to uninstall everything (for good) and reinstall latest GPU drivers.
Then switch autoupdate off (or to "notify only"), in the Nvidia/AMD auxiliary apps (GeForce Experience and the AMD equivalent).


uberslug

  • Sr. Member
  • ****
  • Posts: 286
    • View Profile
Re: MaxHUD plugin
« Reply #734 on: January 20, 2018, 09:39:48 PM »
MaxHUD doesn't show up on my b13. Am I doing something wrong or is it like this for everyone?