PiBoSo Official Forum

GP Bikes => Bug Reports => Topic started by: onearmedbandit on January 05, 2022, 11:03:12 PM

Title: SteamVR issue.
Post by: onearmedbandit on January 05, 2022, 11:03:12 PM
First up, I did look through the forum and saw there was a post in another thread about this issue but I wanted to create a thread on the actual topic.

For the most part GP Bikes (Steam version) works fine with SteamVR. But I was getting crashes to desktop with certain mods (bikes only). After checking I had my installation etc correct I tried the game with SteamVR off, and all these mods worked fine.

For the record SteamVR has worked faultlessly for me with all my other VR titles.

I'm not sure what to do next, the game on Steam states it supports my HMD (HTC Vive Pro) but currently it is a hit and miss situation. I'm hoping someone can either suggest a work around or ideally this issue can be fixed.
Title: Re: SteamVR issue.
Post by: onearmedbandit on January 06, 2022, 10:19:21 AM
Update. I have fixed the issue. When I first started to add content to the game I followed the advice I had seen on these forums, putting the mods into my document>piboso>gp bikes>mods folder but they wouldn't show. I found other guides online including at Steam suggesting I needed to put the mods into the root folder, creating a 'bikes', 'tyres' etc group of folders. I did this and it worked. But the game would ctd on occasion. Leading me to where I found myself at the last post.

Tonight I decided to do a fresh install, but this time I put it on my c: drive as this one of my ssd's. I fired up the game on a base install but my mod content was still there. It then dawned on me that I had left content folders in my documents folder (from a previous test today). So I discovered for myself that for the mods to work from your documents folder the root drive has (in its default setting) to be on the same drive. And now of course, my mods are all working in VR with no ctd.