PiBoSo Official Forum

GP Bikes => General Discussion => Topic started by: PiBoSo on December 09, 2016, 01:09:23 am

Title: GP Bikes beta10c
Post by: PiBoSo on December 09, 2016, 01:09:23 am

GP Bikes beta10c released:
http://www.gp-bikes.com/?page=downloads
( download mirrors would be extremely helpful and welcome )


Changelog
fix: TrackIR rotations
fix: replay bug
fix: race manager bug
fix: reflections bug
fix: plugins rendering bug
fix: replay of the bike reset
fix: more smaller bugs
fix: bike reset bug
fix: reflections and shadows optimization
fix: VR tracking in the external view, too
fix: pitboard bugs
fix: pitboard optimization


Release Notes
- Replays are not compatible with Beta10 and previous
Title: Re: GP Bikes beta10c
Post by: Vergio101 on December 09, 2016, 02:18:42 am
 ;D ;D ;D thanks
Title: Re: GP Bikes beta10c
Post by: Hawk on December 09, 2016, 03:13:26 am
Thank you!  ;D

Hawk.
Title: Re: GP Bikes beta10c
Post by: SwarleyRuiz on December 09, 2016, 08:13:57 am
Thanks Piboso!

Downloading and uploading

http://www.swarleyruiz.com/Downloads/GP-Bikes/Betas/gpbikes-beta10c.exe
Title: Re: GP Bikes beta10c
Post by: Urban Chaos 2.0 on December 10, 2016, 05:51:40 pm
Don't know if anything about the 125rr has changed (I spend 99% of the time playing GP Bikes on the RC990), but the 125rr is a VERY good demo bike. It's fast, and quite fun.
Title: Re: GP Bikes beta10c
Post by: dibu on December 10, 2016, 07:42:46 pm
Here some memory reports (replay=512):

526,148 KB  1st client in garage
526,152 KB  1st client entering track
526,656 KB  2nd client connected to garage

-----------
16,612 KB  Server restart, no clients connected
18,272 KB  Back to "Waiting" after about 10 connects/disconnects, max. 3 simultaneous 

-----------
16,612 KB  Server restart, no clients connected
17,964 KB  Back to "Waiting" after 1 connect/disconnect
Title: Re: GP Bikes beta10c
Post by: PiBoSo on December 10, 2016, 08:08:14 pm
Quote from: dibu on December 10, 2016, 07:42:46 pm
Here some memory reports (replay=512):

526,148 KB  1st client in garage
526,152 KB  1st client entering track
526,656 KB  2nd client connected to garage

-----------
16,612 KB  Server restart, no clients connected
18,272 KB  Back to "Waiting" after about 10 connects/disconnects, max. 3 simultaneous 

-----------
16,612 KB  Server restart, no clients connected
17,964 KB  Back to "Waiting" after 1 connect/disconnect


Thank you for the report.
Title: Re: GP Bikes beta10c
Post by: PeterV on December 11, 2016, 02:44:38 pm
This never happened to me before. all installations where like i had them before, nothing weird or special.
Normally before Beta10c when switching bikes it mostly gave a core.exe, not happened yet but switching bikes resulted in this:
(after it happened i checked bike selection menu again and under the helmet section it showed ?? ??, selecting a helmet it always showed the wrong one)
Restarting the game brought it back too normal status, did not see it happen again, ill keep a look out  ;)

<<< Click picture too enlarge >>>

(http://i.imgur.com/7sGwZGA.jpg) (http://i.imgur.com/7sGwZGA.jpg)

Title: Re: GP Bikes beta10c
Post by: C21 on December 11, 2016, 03:40:29 pm
Happend before.
I suggest it is caused by the rider suit.
The Aprilia suit (Bautista) contains also a helmet paint and this could interfere with the other selected helmet.
Title: Re: GP Bikes beta10c
Post by: Blackheart on December 11, 2016, 03:53:15 pm
Quote from: C21 on December 11, 2016, 03:40:29 pm
Happend before.
I suggest it is caused by the rider suit.
The Aprilia suit (Bautista) contains also a helmet paint and this could interfere with the other selected helmet.


No... its a my skin, there is just the suit.
Title: Re: GP Bikes beta10c
Post by: matty0l215 on December 11, 2016, 05:15:37 pm
Could you change the file name of the helmet peter?

It's not at the 31 character limit but it's worth a shot.
Title: Re: GP Bikes beta10c
Post by: PeterV on December 11, 2016, 07:16:13 pm
Quote from: matty0l215 on December 11, 2016, 05:15:37 pm
Could you change the file name of the helmet peter?

It's not at the 31 character limit but it's worth a shot.

Yep crossed my mind as well, ill have a think about the new name :P
Title: Re: GP Bikes beta10c
Post by: Alone on December 11, 2016, 09:04:32 pm
Thanks for the update.

I just tried my first race in a track with dinamic surface since beta 5. Sorry to report it, but is exactly the same experience as with beta2/3 for me. I wrote the lag-strange things many times, so is easy to remember I guess.
Nothing of those lag things happens in a NDS track, with the same server (dibu's one), same PC, same guys, same bikes, same internet provider.
No core.exe at all, just desynchronization between sessions and lap times with the rest.
Title: Re: GP Bikes beta10c
Post by: PeterV on December 11, 2016, 09:37:21 pm
I have too agree here, 7 riders in server 6 riders around 60 ping except alone with a steady 270.
Start of practice is oke but after 10 min the lag for him starts not so much on track but in chat and timing.
It looks and acts the same as in the old days. (we start and alone is still in the previous session) we will be returning for our races too NDS tracks.
(where we have no problem at all with a 270 ping rider). We will of course test if so needed on the Piboso netcode server.
Title: Re: GP Bikes beta10c
Post by: dibu on December 12, 2016, 07:05:16 pm
Small memory update:

The server was running for about 48 hours.

19,440 KB  Back to "Waiting" after 75 connects/disconnects
16,604 KB  Server restart, no clients connected
16,632 KB  after some minutes without client connect