PiBoSo Official Forum

GP Bikes => Mods => Topic started by: gianni turismo on November 27, 2018, 01:27:30 pm

Title: sound mod
Post by: gianni turismo on November 27, 2018, 01:27:30 pm
hi!
i'm trying to make some sound mod:

https://www.youtube.com/watch?v=ms9xekXZRCU

problem:
watching replay from "tv" style camera the sound it's always like in cockpit view (no passing volume change or doppler effect), 

if i set again  the original engine.scl file , the problem disappears.
i have compared the 2 files and i did not find syntax difference.

can some one help me??  :-\
thanks!  :P
Title: Re: sound mod
Post by: matty0l215 on November 27, 2018, 08:08:54 pm
When you say TV Style, do you mean the 3rd person chase camera (like in your video)?

Title: Re: sound mod
Post by: gianni turismo on November 27, 2018, 09:00:55 pm
Quote from: matty0l215 on November 27, 2018, 08:08:54 pm
When you say TV Style, do you mean the 3rd person chase camera (like in your video)?


hi matty!
no. I mean the fixed point of view from out the track.
that video was  focused on the sound mod test, not about the issue. sorry for the misunderstand.  :-\

tomorrow i will upload a video focused on the issue.  ;D

Title: Re: sound mod
Post by: matty0l215 on November 27, 2018, 09:40:06 pm
No worries. Just more info for others ;)

Title: Re: sound mod
Post by: JohnnoNinja on November 27, 2018, 10:18:43 pm
Quote from: gianni turismo on November 27, 2018, 01:27:30 pm
hi!
i'm trying to make some sound mod:

https://www.youtube.com/watch?v=ms9xekXZRCU

problem:
watching replay from "tv" style camera the sound it's always like in cockpit view (no passing volume change or doppler effect), 

if i set again  the original engine.scl file , the problem disappears.
i have compared the 2 files and i did not find syntax difference.

can some one help me??  :-\
thanks!  :P


I have the same problem when I edited the sounds of the H2R a while ago. I've no idea how to solve this issue. It's like the trackside camera is using the onboard sound:

https://www.youtube.com/v/ruErKBKv8Js
Title: Re: sound mod
Post by: Manu on November 28, 2018, 03:15:35 am
Quote from: gianni turismo on November 27, 2018, 01:27:30 pm
hi!
i'm trying to make some sound mod:

https://www.youtube.com/watch?v=ms9xekXZRCU

problem:
watching replay from "tv" style camera the sound it's always like in cockpit view (no passing volume change or doppler effect), 

if i set again  the original engine.scl file , the problem disappears.
i have compared the 2 files and i did not find syntax difference.

can some one help me??  :-\
thanks!  :P


The sound samples must be saved in mono.
Title: Re: sound mod
Post by: gianni turismo on November 28, 2018, 08:58:41 am
Quote from: JohnnoNinja on November 27, 2018, 10:18:43 pm


I have the same problem when I edited the sounds of the H2R a while ago. I've no idea how to solve this issue. It's like the trackside camera is using the onboard sound:

https://www.youtube.com/v/ruErKBKv8Js


EXACTLY!
Title: Re: sound mod
Post by: gianni turismo on November 28, 2018, 09:01:50 am
Quote from: Manu on November 28, 2018, 03:15:35 am

The sound samples must be saved in mono.


oh... thanks! ;D  i'm going to make a test this evening . stay tuned!  :P
Title: Re: sound mod
Post by: JohnnoNinja on November 28, 2018, 03:42:47 pm
Thnx Manu!
Title: Re: sound mod
Post by: gianni turismo on November 28, 2018, 05:34:04 pm
it worked! thanks Manu! :D