• Welcome to PiBoSo Official Forum. Please login or sign up.
 
May 17, 2022, 10:57:57 AM

News:

GP Bikes beta20e available! :)


SimHub with Steam version of GPB

Started by onearmedbandit, December 22, 2021, 12:41:08 AM

Previous topic - Next topic

onearmedbandit

I have the most recent update for SimHub which has the GP Bikes interface but I can't get it to recognise the GPB for setup and telemetry. As this was integrated with SimHub prior to the steam version being released I am left wondering if the different versions of the sim are causing this. I've asked on the SimHub discord but not had a reply yet, so if anyone is running the steam version with SimHub could you please let me know if there is something I need to do to get it working. Thanks for your time.

onearmedbandit

Ok have it feeding output now (generic but it works), now just find out why SimHub keeps jumping from GPB to MX Bikes. I've removed the MXB folder from SimHub to see if that stops it.

Chris_Beeves

I'm not having any issues. Did you patch the steam version?
I had to try..

onearmedbandit

Quote from: Chris_Beeves on December 22, 2021, 04:46:20 AMI'm not having any issues. Did you patch the steam version?

Thanks for replying. No I can't say I did, clean install from Steam with a few content additions of bikes, tracks and helmets (haven't worked out where suits go yet ha).

onearmedbandit

Turning off auto game detect in SimHub cured the switching but that's not something I've had to do before.

Chris_Beeves

I had to try..

onearmedbandit

Quote from: Chris_Beeves on December 22, 2021, 12:58:15 PMAh.. I never had that on..

Yeah it was on by default, and hadn't been an issue before. I've got a lot of reading to do on this title to get my head around the new environment. BTW, loved your thread on the handlebar setup. It's something I've always wanted to do when the right bike game came along (stupidly I was aware of GPB from a few years ago but never pursued it) so my friend and I will be taking a lot of tips and knowledge from it.

mdlp

Hi there.  I'm having exactly the same troubles as you with telemetry not being configured and auto-switching to mx bikes.
The auto-detect sorted the latter, but did you make progress getting the telemetry sorted out?

Cheers, Mark.

mdlp

Turns out it wasn't complicated to remedy, although it wasn't clear either.

So if anyone else encounters this, within the \SimHub\_Addons\GamePlugins directory are sub-directories for all supported titles. Within GPBikes is an install.pak and a sub-dir containing proxy.ini.  Simply copy proxy.ini to the directory where GPB is installed and all comes to life.

Chris_Beeves

Auto switching messes stuff up for me even when telemetry works.
I just turn it off, but then again I almost only use GPbikes with simhub.
I had to try..