• Welcome to PiBoSo Official Forum. Please login or sign up.
 

The last time I ask for help

Started by JOACKO172, March 25, 2018, 03:26:24 am

Previous topic - Next topic

h106frp

Miight be the easiest thing to try, just back up the original model first.

JOACKO172

Quote from: h106frp on March 25, 2018, 07:55:56 pm
Miight be the easiest thing to try, just back up the original model first.

Now i need to create the race data again? Because the game crashes

h106frp

Certainly the .trp file - hopefully you saved the centreline, you can then load racedata to view and hopefully just save out with new heights

As far as I can work out the centre line is 'dropped' onto the model to calculate the track heights

JOACKO172

Quote from: h106frp on March 25, 2018, 09:00:53 pm
Certainly the .trp file - hopefully you saved the centreline, you can then load racedata to view and hopefully just save out with new heights

As far as I can work out the centre line is 'dropped' onto the model to calculate the track heights

I will do everything from scratch because now the game is crashing, super sad hahaha

JOACKO172

Ok. I made everything again, the track is working but i go some steps back. i have the same problem with the dark track. I donĀ“t know what i need to do

h106frp

Post the track and I will have a look and see if I can work it out

JOACKO172


h106frp

There appears to be a fundamental problem with the way you have textured the model and everything just has a default dark grey diffuse and no texture.

The model should have texture based material applied to all surfaces. If you can export and post a .fbx I might be able to look in Blender otherwise someone familiar with 3DS will need to look

JOACKO172

Quote from: h106frp on March 25, 2018, 11:51:45 pm
There appears to be a fundamental problem with the way you have textured the model and everything just has a default dark grey diffuse and no texture.

The model should have texture based material applied to all surfaces. If you can export and post a .fbx I might be able to look in Blender otherwise someone familiar with 3DS will need to look

I think the problem is i imported the 3d into 3ds as .gmt and i exported it as .edf. I am going to save everything in fbx and then convert it to edf to test something different

h106frp

If you are working in 3DS then you just use the exporter to create the .map and .trp, .edf is only used for the background strip.

You need to check your materials have the textures assigned to the diffuse channels. Think its the teapot icon (about the limit of my 3ds knowledge)

JOACKO172

Quote from: h106frp on March 25, 2018, 11:51:45 pm
There appears to be a fundamental problem with the way you have textured the model and everything just has a default dark grey diffuse and no texture.

The model should have texture based material applied to all surfaces. If you can export and post a .fbx I might be able to look in Blender otherwise someone familiar with 3DS will need to look

http://www.mediafire.com/file/39ihc1vx19cy3ym/fbx.rar

JOACKO172

Ok everybody i am looking at this tutorial http://forum.kartracing-pro.com/index.php?topic=196.0 and i see i make some wrong things with the textures so i am going to review that and post if i gain something. Thanks!

h106frp

Working track folder  :)

https://drive.google.com/file/d/1h1ORXm9qom7W98QQruTaXdrHY8va3O5_/view?usp=sharing

New .fbx is in the folder as well.


New CL
New background to seal horizon gap
Added stall.edf
New racedata

Fixed surface definitions, split model down to fix objects etc
New fbx should be a good base for any further improvements you want to add.

Good luck  :)

JOACKO172

Quote from: h106frp on March 26, 2018, 07:19:28 pm
Working track folder  :)

https://drive.google.com/file/d/1h1ORXm9qom7W98QQruTaXdrHY8va3O5_/view?usp=sharing

New .fbx is in the folder as well.


New CL
New background to seal horizon gap
Added stall.edf
New racedata

Fixed surface definitions, split model down to fix objects etc
New fbx should be a good base for any further improvements you want to add.

Good luck  :)

Do yo change something in the textures? Because if no i am making a disaster, thank you so much for the help!

h106frp

Extracted your fbx 2010 but then had to re-pack as fbx 2013 to load into blender.

Loaded OK into Blender with textures correctly referenced in materials, fixed model and built track using 3dsmax and 64bit exporter.

Re-packed the .fbx with textures in the 2010 format the same as originally supplied for sending back to you - used Autodesk fbx converter for pack/unpack

You had some faulty model declarations which might not of helped but your model export must have been basically correct with material assignments so I am not sure where you are having problems exporting to .map/.trp

The supplied fbx is 'good' so you can experiment with the exporter and try to mimic the result.