• Welcome to PiBoSo Official Forum. Please login or sign up.
 
October 21, 2019, 08:32:38 pm

News:

GP Bikes beta16b available! :)


Fbx2edf not creating file

Started by TheFatController, July 02, 2018, 08:09:10 am

Previous topic - Next topic

TheFatController

July 02, 2018, 08:09:10 am Last Edit: July 02, 2018, 08:37:32 am by TheFatController
Hey all..

Just wondered if anyone's had this before.

Fbx2edf (latest version and previous) suddenly doesn't want to output anything..

It all looks like it runs well, and gets to ending log, but the file isn't updated, and if no file exists to overwrite one isn't created.

Any ideas what could have suddenly gone wrong  or is anyone else finding this? Any ideas for a fix?

Thanks :)

Grooveski

July 02, 2018, 12:30:09 pm #1 Last Edit: July 02, 2018, 12:33:22 pm by Grooveski
No problems here using the latest version(for tracks).

Could you be working somewhere that doesn't have write permission(or needs admin privilege to write)?  I just moved to win10 and noticed Program Files is now an admin folder...

...or how about folder names?  Long path names can cause problems with some programs.

matty0l215

July 02, 2018, 01:37:47 pm #2 Last Edit: July 02, 2018, 05:52:26 pm by matty0l215
Odd. Tried re-downloading FBX2EDF??

That or there may be somthing wrong with your input files maybe?

TheFatController

Thanks guys, I've litterally exported this bike as it is 50 or so times before..

:(

TheFatController

Ok quick update.. it works if I don't include the export script..

But I've tried different directories and even using the stock export script and stock template folder structure..  🤔

matty0l215

What are you exporting out of interest??

TheFatController

A bike.. a new model I've made.

Its in game, in fact I've exported the model about 50 times with updates and all of a sudden it doesn't like the export script.

The script creates all model parts within a model.edf, as opposed to exporting them all separately which is what I'm looking into doing now.

Its a shame because the export script makes it so easy.

matty0l215

I have had this once before but i can't remember how i fixed it

It was either re-downloading EDF2FBX, When an update came out for EDF2FBX Or it was something to do with the model/export script

I've only ever used scripts to export, so much easier to work with :)

TheFatController

Thanks for the hints.. Unfortunately I'm having zero luck.

Any other suggestions? Anyone? This is driving me insane lol.. I've tried exporting the bike parts separately but it messes up the geom which was SO perfect as it was.. :(

h106frp

Can you post the script file?

Full path with .ini entered in the script path box?

TheFatController

Sure:



This is just my latest attempt, newly downloaded FBX2EDF, new folder..

h106frp

Looks OK, I do not normally add a save path, just add the scipt path and hit OK.

Notice that its the new x64 version. Does it work with the original 32 bit fbx2edf ?

TheFatController

I've just tried without a save path and still no joy. Also tried with both versions of FBX2EDF.

It skips straight to ending log, looks like it's completed everything but in seconds and no file is created :(

Thanks for looking h106frp

h106frp

July 02, 2018, 08:42:05 pm #13 Last Edit: July 02, 2018, 08:48:32 pm by h106frp
I have had this when the pivot references in the model (names or hierarchy) do not agree with the names in the script.

Open 3D viewer is a quick and easy way to independently view an fbx and its hierarchy.

http://www.open3mod.com/

Just remembered another sinister issue  :)
If you have any 'empty' model objects (name defined but no geometry and usually caused be deleting all the points while in edit mode rather than deleting an object in object mode it trips up fbx2edf.)

In open viewer look for objects with a little blob next to the name in the tree as these will be empty

TheFatController

Thanks h106frp,

I think we both came to the same conclusion at the same time. I checked the exported FBX in Notepad++ and searched for the word 'chassis'. I could only find 'chassis.pivot' etc..

I checked my RM250 model and right there is 'chassis' and other references. Exploring this in Blender I tried exporting the model with both 'empties' and 'mesh' selected, and what do you know! It works.

I've never had to do that before. My guess is that somethings gone wrong with the blend and it wasn't including them anymore.

Thanks for all your help everybody, much appreciated. 8)