• Welcome to PiBoSo Official Forum. Please login or sign up.
 
April 10, 2020, 03:45:54 am

News:

GP Bikes beta17 available! :)


CAWS MOD Team - Net Dash for Android Devices

Started by matty0l215, November 06, 2018, 07:54:36 pm

Previous topic - Next topic

javiliyors


davidboda46

Quote from: javiliyors on September 13, 2019, 07:36:39 amWorks in B16b?

I've tried and it doesn't seem to work..., used same setting as the previous beta... and then some others but no luck... Update incoming Caws?

Cheers,

/David "Gonzo" Boda #46
"THE EDGE... THERE IS NO HONEST WAY TO EXPLAIN IT BECAUSE THE ONLY PEOPLE WHO REALLY KNOW WHERE IT IS ARE THE ONES WHO HAVE GONE OVER"

maggikk22

Hi all,

looks like I'm late... after more than a year, I'm discovering my code has been turned into an Android app! So cool!
I would love to see it working on my phone!

Unfortunately, it looks like it does not work with Beta 17 neither...
I haven't tried my original Processing code with the Raspberry screen because it is much too heavy and requires an USB and HDMI cables. Not comfortable...

Any chance for an update?


You cannot see attachments on this board.You cannot see attachments on this board.

h106frp

Hi maggikk,
The data stream parsing needs updating as more parameters were added in the last couple of betas, I will try and have a look if I get a bit of time.
 I did get it working quite well with a rpi using a directly connected touch screen and wireless connection which removes the heavy cables.

h106frp

February 26, 2020, 12:01:30 am #34 Last Edit: February 27, 2020, 12:23:11 am by h106frp
Hi again,
The original mk1 (post #1) dash app probably will not work as PB updated the .dlo and the data stream.

Thread is a bit of a mess but the mk2 dash (which is the supported one) is in post #25.

If anyone can try running mk2 and report any errors I would be grateful as after updating the android developer app. and setting up for my new phone the original code appears to work. Just trying to work out how much updating is required.

Thank you


maggikk22

I tested the MK2.
Data link works (led is on).
When the game is paused, the app recognizes it (message saying "on track, simulation paused").
But when I resume the game, nothing happens, the app stays in Pause mode.
And when I launch the app while on the track, nothing but a light grey background appears on the screen.
Hope this helps ...

maggikk22

I've just tried my old Processing code with Beta 17. It works!
This means the data parsing has not been modified since Beta 14, right?


h106frp

Fairly sure some extra bits were added after b14 but I will have a look at the output later on. At least you are up and running  :)

h106frp

Hello Magikk

In the proxy_udp.ini file do you have the line

info = 1

to enable the streaming of the event, session, lap and split data.

maggikk22

no, I don't...
I just use the bike data, not the session info.


h106frp

The mk2 dash uses(needs) the session data to set up the shift lights, rev range etc and detect bike changes

I will need to do an update as I found a couple of bugs to fix anyway

Myst1cPrun3

Quote from: h106frp on February 26, 2020, 08:57:37 pmThe mk2 dash uses(needs) the session data to set up the shift lights, rev range etc and detect bike changes

I will need to do an update as I found a couple of bugs to fix anyway

I've been meaning to get this since I lost my vr use.
Good to see it get some updates.