• Welcome to PiBoSo Official Forum. Please login or sign up.
 
June 19, 2019, 10:59:05 pm

News:

World Racing Series beta14 available! :)


Help, weird edge.

Started by davidboda46, March 24, 2019, 01:49:52 pm

Previous topic - Next topic

davidboda46

Hi guys.

Need some help. Finished my M2 Leftist Punk Skin. I have a slight problem with the "46", the front star and the white/carbon background. It looks fine in Photoshop but the finished version in GPB have some weird edge problem, with black squares, jagged edge (see picture in full size). Does anyone know why this happens and if there is a possible fix?

Cheers,

/David "Gonzo" Boda #46

"THE EDGE... THERE IS NO HONEST WAY TO EXPLAIN IT BECAUSE THE ONLY PEOPLE WHO REALLY KNOW WHERE IT IS ARE THE ONES WHO HAVE GONE OVER"

Myst1cPrun3

I've had a few issues like this, and often it's when I'm going near an edge and overlap onto a bit of the livery I haven't seen. Can look a little weird.
I'd check all black bits and see if there's a matching pattern somewhere, but it's in an awkward place for it to be that really.

Blackheart

In Gpbikes.ini add this:

[core]
texture_quality = 1

Its better use the defaut one (4) for online races

maggikk22

I think it is because of some remaining transparent pixels, probably due to the use of layers in the design software.

bison160

The texture quality should help, but any time you use red on a diagonal line, you will get some issues like that because of the texture compression. Might play around with some of the settings when saving it out of photoshop as well.

davidboda46

Thanks guys.

Will try the texture_quality = 1 and play around with export options to see if any of it makes any differens. Can't see anything weird when I reopen the .tga image in photoshop though so not sure if export changes will make a difference, but who knows.

Cheers,

/David "Gonzo" Boda #46
"THE EDGE... THERE IS NO HONEST WAY TO EXPLAIN IT BECAUSE THE ONLY PEOPLE WHO REALLY KNOW WHERE IT IS ARE THE ONES WHO HAVE GONE OVER"

davidboda46

Tried pretty much everything you guys suggested and anything I could think of, the only thing that solved the problem was:
[core]
texture_quality = 1


But I guess it will have a negative effect on the overall performance ingame? 

Cheers,


/David "Gonzo" Boda #46
"THE EDGE... THERE IS NO HONEST WAY TO EXPLAIN IT BECAUSE THE ONLY PEOPLE WHO REALLY KNOW WHERE IT IS ARE THE ONES WHO HAVE GONE OVER"

Blackheart

Texture 1 use uncompressed textures, so is faster and with the best quality.

With bigger tracks and a lot of bikes, you can have some issue with the framerate.



Myst1cPrun3

Whenever I get this issue I erase the line, and change the thickness by +- 1 then redraw, seems to sort it for me