• Welcome to PiBoSo Official Forum. Please login or sign up.
 
July 29, 2021, 06:59:29 PM

News:

World Racing Series beta14 available! :)


Background.edf too high.

Started by Grooveski, February 17, 2017, 07:03:02 PM

Previous topic - Next topic

Grooveski

February 17, 2017, 07:03:02 PM Last Edit: February 17, 2017, 07:22:06 PM by Grooveski
Hi Piboso.

I've two tracks here that I've made landscape models for but am having the same problem with each.  When you play them the background is too high.





Have checked the models(and Hawk double-checked) and the heights are fine up to conversion(using FBX2EDF). 
The main and background models line up again when the FBXs are re-combined.

It looks like perhaps the insertion point in GPB for the background.edf isn't the same as the one for the main track model.

PiBoSo


The background scene is always centered on the camera.
"Obviously your ambition outweighs your talent".

Grooveski

OK, I've obviously mistaken what was meant by a background model. 
I think I get it now - that's for a horizon ring.

What I'm after is somewhere to put a 3d landscape where it won't be cut off by the draw distance.
If the whole model is put in the .trp the model is cut off(that's it fading out along the treeline).



Manually increasing the drawdistance in profile.ini allows the whole model to be seen but the drawdistance is reset back to 1km any time you go into settings.



Any chance you could raise the draw distance? 
1km is very low and means every single track has pop-up trees and buildings.  If the distance slider went from 1km at the lowest to maybe 10km at the top end the tracks would all look nicer for it.  :)