• Welcome to PiBoSo Official Forum. Please login or sign up.
 
August 12, 2020, 08:58:06 PM

News:

World Racing Series beta14 available! :)


Laptimes not showing in GPB record page when hosting ?

Started by HornetMaX, January 22, 2014, 03:19:16 PM

Previous topic - Next topic

HornetMaX

Hi all,

I've a weird problem I've never noticed before: if I join one of dibu's servers and do a personal best, it shows up on GPB stats page (http://stats.gp-bikes.com/records.php).

If I start a dedicated server on my own and join it, if I do a best lap it does not appear in the stats page. Any idea ?

Here below my dedicated.ini.

[connection]
name = MaX dedicated server test
maxclient = 10
password =  blabla
admin_password = blablabla
bandwidth = ; 0 -> low, 1 -> medium, 2 -> high
max_ping = 1000
whitelist = ; the filename of the whitelist
blacklist = ; the filename of the blacklist
polls_disable = 1; if set to 1, polls are disabled
MOTD = The Dude: Obviously you're not a golfer.; message of the day

[export]
results =  html; html or xml, If set it will automatically export results at the end of the race
directory = C:\Program Files (x86)\GP Bikes beta4b\gpbikes; the directory where results will be saved ( must exist )
units =  0; 0 -> metric units, 1 -> US units, 2 -> UK units

[replay]
save = 1; 0 or 1, If set to 1 it will automatically save the full replay at the end of the race
directory = C:\Program Files (x86)\GP Bikes beta4b\gpbikes; the directory where replays will be saved ( must exist )

[event]
track = victoria; track ID ( for ex. Victoria )
track_layout = ; track layout ( for ex. Short ). Empty -> Default;
category = ; bike category allowed. Empty -> Open; GP125; GP125 Cup; GP500; GP1000

[rating]
class = ; A -> 2000+, B -> 1600-1999; C -> 1200-1599; D -> 800-1199

[weather]
realistic = 0; 0 or 1, if set to 1, following params are ignored
conditions = 0; 0 -> sunny, 1 -> cloudy, 2 -> rainy
temperature = 28; air temperature, celsius
wind_direction = 0; 0 -> north, 1 -> north-east, 2 -> east, ..., 7 -> north-west
wind_speed = 0; meters/second
track_conditions = 0; 0 -> dry, 1 -> wet

[hardcore]
force_cockpit = 0; 0 or 1
no_aids = 0; 0 or 1
limited_tyre_sets = 0; 0 or 1

[race]
quick_race = 0; 0 or 1. If set to 1, practice, warmup, sighting lap and warmup lap are skipped
practice_length = 300; minutes
qualify_length = 300; minutes
warmup_length = 300; minutes
sighting_lap = 1; 0 or 1
race_length = 30; % of full length
restart_delay = ; server restart time in seconds
pause = 0; 0 or 1. If set to 1, the event is paused and saved at the end of "pause_session"
pause_session = ; practice, qualify, warmup or race
pause_directory = ; the directory where data is saved. The default is "resume"
resume = ; the file to load to resume an event

[live]
enable = ; 1 to enable live timing
port = ; the UDP port
password =


MaX.

janaucarre

Hello,
I do a test on hotlap 500 johor, my time was 1.49, after that i host on johor with the same 500,  i made 1.37.
My time on hotlap was on the records page, and when i made 1.37 on my own session this time replaced the 1.49. All is ok for me.

HornetMaX

My fault: if you have a local server and connect to it via the World list of servers, everything is fine.
If you connect to it from the "local" list of servers, then laps are not registered.

@Piboso: is my understanding right ? Is the behavior intentional ? If yes to both, I may want to precise this in the GPB guide.
Personally I'd be tempted to say that the code should always try to send the lap info to the stats server (of course handling cases where playing on a LAN there's no internet connection so the "send" can fail).

MaX.

janaucarre

OK, i ever have noted that, for me it was not a problem, but if it is...