• Welcome to PiBoSo Official Forum. Please login or sign up.
 
April 23, 2019, 12:14:31 am

Chain lods not work

Started by Manu, June 17, 2018, 01:28:20 am

Previous topic - Next topic

Manu

June 17, 2018, 01:28:20 am Last Edit: June 17, 2018, 01:36:23 am by Manu
The chain becomes invisible at the lod levels. It also happens on the default game bikes.

https://www.youtube.com/v/sVZswjy1FIs

Grooveski

This is similar to something I've seen with wire fences and football nets at the track I'm working on.

it was also kind of happening with the trees.  At a distance most of them were taking on a silver tint around the edges.
All the textures were well checked to make sure the transparency alpha matched the image edges and that the alphas were B/W only(i.e. no greys).  They were all fine.

One skin was acting different - the background colour on that was black - and those trees got darker at a distance.  All the others had a white background.
...so I tried changing one of the white backgrounds to green and done another conversion.  Now that tree type showed as green at a distance.

...and I think this may be why my fences are disappearing.  They have a silver fence image on a black background and I think the black is weeping in as the distance increases.  I'm going to try changing them to a mid grey background.

...which is what I suggest you try too.   ;)

Sorry to be suggesting something that I haven't even tried myself yet.   :-[  Only came up with the theory a couple of days ago but have been upgrading my computer since then.

...and I know that by rights the background colour shouldn't play a part in a transparent texture - but judging by what's happening with the trees - it does.
I think it may in some other games as well - The Dirt series has green tree backgrounds and I'm sure I've seen them elsewhere too.

Grooveski

When I tried the background thing on the fences it worked a little bit - but not enough.

...so I kept playing around - and what seemed to have much more effect was increasing the skin size.
I just doubled the dimensions of the fence textures and now they're showing up at higher distances. 

Manu

June 22, 2018, 03:02:17 pm #3 Last Edit: June 22, 2018, 03:24:16 pm by Manu
Hi Grooveski.

Your case is different.

The error that I'm mentioning refers to the "LOD" models (Level Of Detail). These are models with a lower number of polygons that are rendered according to the distance of vision.

In this case, I'm showing how the chain disappears when a model with a lower resolution should appear instead.

I'm afraid that the LOD models are being represented at the same time in the level 1.