• Welcome to PiBoSo Official Forum. Please login or sign up.
 
October 25, 2020, 07:14:26 PM

News:

World Racing Series beta14 available! :)


MaxTM telemetry - put your comments here.

Started by HornetMaX, May 28, 2014, 11:30:56 PM

Previous topic - Next topic

C21

Sorry MAx i overread this  :o

QuoteWhat do you want to see as scale on the left axis ?
    Do you want the 3 lines to occupy exactly the same rectangular space or do you want them to be slightly offset vertically (to avoid them overlapping too much) ?
    If offset, do you need a left axis 9with the scale) for each line ?
    If I had to put a limit to the number of lines that can go on the same graph, what would be reasonable ?
1) Don´t get it. The scale changes using different Y-Axis parameters (speed, gear,...)
2) Same rectangular space
3) NA
4) 5
# Member of the CAWS Racing Team #


HornetMaX

Quote from: C21 on November 11, 2015, 09:19:49 AM
Sorry MAx i overread this  :o

QuoteWhat do you want to see as scale on the left axis ?
1) Don´t get it. The scale changes using different Y-Axis parameters (speed, gear,...)
Example: let's say I plot RPMs, speed and gear on the same graph.
The left axis will have a scale for RPMs, so maybe something like 0-20,000 RPM.
But how do you read the scale for the other two lines (speed and gear) ?

C21

QuoteBut how do you read the scale for the other two lines (speed and gear)
Scale independently.
See: http://www.kc-t.biz/blog/wp-content/uploads/2014/01/Blog-Graph-ThrotBrake-Jan-14.jpg
# Member of the CAWS Racing Team #


HornetMaX

Quote from: C21 on November 11, 2015, 11:02:32 AM
QuoteBut how do you read the scale for the other two lines (speed and gear)
Scale independently.
See: http://www.kc-t.biz/blog/wp-content/uploads/2014/01/Blog-Graph-ThrotBrake-Jan-14.jpg
I mean the user, not the software. In your pic, there are 2 scales (45-90 and 3000-7500) but 3 lines. One line has no visible scale.

HornetMaX

Here you have some pro examples:

GEMS:


ATLAS 1:


ATLAS 2:


I think you're asking for something like the Atlas 2 image (top right plot). But notice that some lines have a vertical offset with respect to others (to avoid a total overlapping mess).

I'l have a look eventually, but only after I've made the tool work with GPB b7, WRS b7, KRP b14 (and maybe MXB b4, if it gets out quickly).

C21

QuoteI think you're asking for something like the Atlas 2 image (top right plot). But notice that some lines have a vertical offset with respect to others (to avoid a total overlapping mess).
100% correct.

On the pic i´ve posted Brake and Throttle uses the same scale.
# Member of the CAWS Racing Team #


HornetMaX

Quote from: doNico on October 23, 2015, 04:31:24 PM
Hey MaX,

i tried to download the file but it says, its "infected by a virus, only the owner is able to download it"
Just for information (as you may have noticed that I now host my stuff on Mega): I had to send a bunch of false positive reports to the one and only antivirus (ClamAV) that was flagging the files as infected. Despite the fact it was quite obviously a false positive (the "infected" files were 3 Qt dlls ...) it took quite while for them to finally solve the issue. So bottom line, the files are now declared clean by virustotal.com.

I'll still keep them on Mega instead of Google Drive (it's more plractical, for various reasons).

P.S.
Virus creators should die and go to developer's hell (a place where you're obliged to use VisualBasic 24/7).



C21

Max, is it correct that TC and EB are not working in TM?
I can display them but got no values.
I´m testing the Moto3 Bikes and got no values on display.
All other gems working fine  :)
Really nice tool!!

Got a error message:
Warning1: "WTiming jump (C:/.......*.maxtm.data.bin): 44.874 -> 45.08
Warning2: "WTiming jump (C:/.......*.maxtm.data.bin): 1073.04 -> 1073.27

What does that mean?
# Member of the CAWS Racing Team #


HornetMaX

Quote from: C21 on November 17, 2015, 10:54:15 AM
Max, is it correct that TC and EB are not working in TM?
I can display them but got no values.
I´m testing the Moto3 Bikes and got no values on display.
Uh, but are moto3 supposed to have TC and EB ?

I think what you get in the telemetry is the setting you're currently using (e.g. TC = 0, 1, 2), not if the TC is currently cutting.
Try with the 990: se the TC at 3, do half a lap and then change it while on the bike. You should see it in the telemetry.

Quote from: C21 on November 17, 2015, 10:54:15 AM
Got a error message:
Warning1: "WTiming jump (C:/.......*.maxtm.data.bin): 44.874 -> 45.08
Warning2: "WTiming jump (C:/.......*.maxtm.data.bin): 1073.04 -> 1073.27

What does that mean?
It's just a warning to signal that the elapsed time between two consecutive telemetry lines is (too) different from the expected value (0.1s).

Notice that when testing offline, if you press ESC the simulation is suspended (i.e. GPB time is frozen), but the windows timer keeps on running (so you get a warning).

C21

QuoteUh, but are moto3 supposed to have TC and EB ?
Yes  :)

I will test it with the Muru. Will see...
BTW: Both were set to "2" on the Moto3.

QuoteNotice that when testing offline, if you press ESC the simulation is suspended (i.e. GPB time is frozen), but the windows timer keeps on running (so you get a warning).
Correct, i stopped the bike and took a screenshot. Thx.  ;D
# Member of the CAWS Racing Team #


C21

Did the test.
As you said: Displayed is the switched position of EB or TC. Best viewed when switching the settings within one lap.

As the front and rear brake temperature is displayed in the dev mode....are you able to log it to the logger (did not remember if i asked it before.. ??? )
# Member of the CAWS Racing Team #


HornetMaX

Quote from: C21 on November 18, 2015, 05:38:52 PM
As the front and rear brake temperature is displayed in the dev mode....are you able to log it to the logger (did not remember if i asked it before.. ??? )
No I'm not, nothing new is passed in the plugin interface.

Also, it would be nice if it was actually confirmed that what we see in debug mode are the brake temps. Just to be 100% sure ...

doNico

Hey MaX ...

just did some laps at Castle Comb ... i tried to open the program but nothing happens :( theres no error shown or anything. I used to put it on my desktop, didnt work ... used to put it somewhere else .. didnt work ... used to download it again .. didnt work ... mhmm?? Its shown in Task Mngr but im not able to close it ... "Permission denied"

~doN

C21

@Nico
QuoteJust copy the appropriate .dlo and the MaXTM_data to the GPB/MXB/WRS/KRP plugins folder.
Do you hear 3 heartbeats when joining the track?
# Member of the CAWS Racing Team #


HornetMaX

Quote from: doNico on November 19, 2015, 01:19:50 AM
Hey MaX ...

just did some laps at Castle Comb ... i tried to open the program but nothing happens :( theres no error shown or anything. I used to put it on my desktop, didnt work ... used to put it somewhere else .. didnt work ... used to download it again .. didnt work ... mhmm?? Its shown in Task Mngr but im not able to close it ... "Permission denied"

~doN
Do you mean you can't run the MaxTM_Viewer.exe ? Very weird, especially that you don't get any error and the "permission denied" stuff ...

1. Are you using the latest version of MaxTM (1.11) ? (shouldn't make any difference to your problem, just for me to know)

2. Which windows version are you on ?

3. As said by C21, is the plugin working ? When you go to track, do you hear an heartbeat sound for a few seconds ? Do you have telemetry files (*.data.bin and *.info.bin) in the MaXTM folder ?

4. Can you check if you already have the "Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)" already installed (Control panel/Program and Features) ? If not, install it and retry (https://www.microsoft.com/en-us/download/details.aspx?id=8328)