• Welcome to PiBoSo Official Forum. Please login or sign up.
 
July 02, 2020, 03:47:58 PM

News:

World Racing Series beta14 available! :)


Transparent track

Started by h106frp, April 16, 2017, 01:36:07 PM

Previous topic - Next topic

h106frp

Any idea why the TRK might appear transparent in game, not rendered in TrackED but looks OK in Mapviewer?

Tried all sorts but the occurence appears almost random between builds

Hawk

Quote from: h106frp on April 16, 2017, 01:36:07 PM
Any idea why the TRK might appear transparent in game, not rendered in TrackED but looks OK in Mapviewer?

Tried all sorts but the occurrence appears almost random between builds

If you haven't got an alpha on the track texture/s then I would try totally deleting the shader/s for the track surface and create a new one/s as appropriate. It's done this in the past to me too and if all other solutions fail this is what I do to solve it and it always worked for me in the past. I'm still not sure what causes the transparent shader issue at times but it's a pain in the butt when it happens.  ;)

Hawk.

h106frp

OK, i will give it another try - about run out of patience with it  >:(

h106frp

April 16, 2017, 07:41:00 PM #3 Last Edit: April 16, 2017, 07:44:02 PM by h106frp
Removed all shaders - problem persists  >:(

Visible in mapview but not tracked  ???

Compiled using 2010 64bit plugin

Hawk

Quote from: h106frp on April 16, 2017, 07:41:00 PM
Removed all shaders - problem persists  >:(

Visible in mapview but not tracked  ???

Compiled using 2010 64bit plugin

Can you PM me a link to the track files H, I'll have a look and see if I can see any issues.  ;)

Hawk.

h106frp

April 16, 2017, 09:18:02 PM #5 Last Edit: April 16, 2017, 09:24:31 PM by h106frp
Will do, definately connected to TRK... declaration, same material/texture/shader declared as OFF_TRK... displays OK.

Starting to think its an exporter bug rather than the (admittedly large) model.

Seems to effect TRKASPH (B and C), TRKKERB, TRKCONC but not TRKGRAS, TRKLINE, TRKSOIL

h106frp

OK, so I built another track, similar geometry and textures - compiles fine with standalone fbx2edf

Using Max2010 and the plugin - transparent track

Any idea which settings I should check in Max as this is obviously the problem

Thank you

h106frp

OK, delving deeper I noticed its any surface that is marked green in TrackED surfaces that is effected ie asphalt and kerbs

Renaming just TRKASPH to OFF_TRKASPH makers the texture normal (visible) for both asphalt and kerbs, it also compiles in about 1/5 of the time

So can I discount any issue with mapping, texture and normals?

The track surface is quite heavily triangulated, would this create any particular issue for the convertor?   Using 64bit 3ds plug in.

Thank you

TheFatController

How have you named / grouped the objects in blender?

h106frp

May 03, 2017, 05:41:29 PM #9 Last Edit: May 03, 2017, 05:48:32 PM by h106frp
Everything is named OK and I avoided doing any clever pivoting or grouping. Strangely the track compiled using OFF_TRKASPH is rideable, has bike shadows and gives lap times, weird!

I am using an original .trp in the track folder that was created using TRKASPH so I get a green surface - that might be why it rides - if this is a workaround then I am a bit happier. From what I have observed TrackED lifts its graphics from the .map - so I seem to have an invisible object TRKASPH and a visible OFF_TRKASPH in the same place at the same time due to the seperate compiles. Must be something clever I can do with this  ;) ;D

Just to confirm, building .trp and .map correctly gives the transparency issue  :(

PiBoSo

Quote from: h106frp on May 03, 2017, 05:41:29 PM
Everything is named OK and I avoided doing any clever pivoting or grouping. Strangely the track compiled using OFF_TRKASPH is rideable, has bike shadows and gives lap times, weird!

I am using an original .trp in the track folder that was created using TRKASPH so I get a green surface - that might be why it rides - if this is a workaround then I am a bit happier. From what I have observed TrackED lifts its graphics from the .map - so I seem to have an invisible object TRKASPH and a visible OFF_TRKASPH in the same place at the same time due to the seperate compiles. Must be something clever I can do with this  ;) ;D

Just to confirm, building .trp and .map correctly gives the transparency issue  :(

Could you please upload somewhere the files with the transparency problem?
"Obviously your ambition outweighs your talent".

h106frp

Hello PiBoso,
I have sent a PM with the link to the files.

Thank you for offering to assist in reviewing the files as I have just about exhausted everthing I can think of.

PiBoSo


Unfortunately there is no easy solution.
It could be possible to rewrite the data format to use less memory.
However it would take a lot of time. An easier, quicker and more future-proof alternative is to create a 64bit version of the whole pipeline: exporters, tools, GP Bikes.
"Quicker" doesn't mean it can be done overnight, though  :(
"Obviously your ambition outweighs your talent".

matty0l215

Future proof is best. The tools have worked up until recently but with larger tracks and more detailed bikes they are showing their limitations...

Understandable that it will take time but it will pay off when done! Especially a 64Bit Core engine.

Napalm Nick

Quote from: PiBoSo on May 04, 2017, 10:05:56 PM


...... is to create a 64bit version of the whole pipeline: exporters, tools, GP Bikes.




No more LAA HACK   8)
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"