• Welcome to PiBoSo Official Forum. Please login or sign up.
 
November 25, 2020, 01:15:10 PM

News:

World Racing Series beta14 available! :)


Bike MOD revived.

Started by Klax75, February 28, 2014, 08:09:49 PM

Previous topic - Next topic

Hawk

Quote from: Napalm Nick on May 23, 2015, 07:10:51 AM
Yikes not Good Hawk.  :'(

I downloaded the Mega BikeMod.zip and ran it on a PC to access my server and it worked OK last week.

I also carried out a comparison (like Peter did) check and there were just a few anomalies - IE no critical to mis-match files.

One thing I would say is to clear your buffers with a PC restart after putting the files in, I had this problem twice before I figured it.

Failing that. My servers are both only the GP500 I would highly suspect the Aprilia not being 'the latest' or something else with it. Maybe remove it and try again to prove?

Hope it helps let us know mate.

I seem to remember we had this same issue last time between downloading just the changed bikes and the whole BikeMOD.zip file..... Seems to me there must be a difference between the two compilations in the bikeMOD database somewhere..... I'm dam sure the problem lies with using auto-sync to update the database because we never had these problems when it was updated manually.... I've never trusted autosync, had problems with it not updating correctly in the distant past so I've never trusted autosync since and never ever will again.  ::) :P

I bet my life that if I download and install the whole bikeMOD.zip file(same as you did to update your server) I'll be able to connect with no problem.....

I'll report back here with my findings after I've deleted all bikes and installed the latest full BikeMOD.zip file.  ;)

Hawk.

Napalm Nick

Captain Hawkster I am pretty sure you are completely right.

However, not fair to blame autosync if auto sync is exactly the same as Bike mod.zip??  Better to blame the loose files not reflecting the other two?

Poor auto sync lol. Is it supposed to mirror Bike mod.zip or Bike mod.loose files everywhere.

You know I'm kidding about mate, the pain we went through last time sent me a twid mad.  ::)

"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

Napalm Nick

When I get a minute I will do a .zip vs .loose GP500 comparison too. My money is still on the RSW.
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

Napalm Nick

May 23, 2015, 10:41:34 AM #453 Last Edit: May 23, 2015, 10:48:31 AM by Napalm Nick
And I would of lost my money

all compared and correct - the only one I don't compare is the VARESE.

Now, this isn't in the BikeMod because it is a STANDARD bike - so is it a case of you have extracted the VARESE? Hence Mis-match ????

;D
Quote from: Hawk UK on May 23, 2015, 10:01:03 AM

I bet my life that if I download and install the whole bikeMOD.zip file(same as you did to update your server) I'll be able to connect with no problem.....

Hawk.

I only betted money and lost, beware.  Fortunately, you will win with this statement - as it will replace the bikes folder and replace an extracted Varese!  (assuming My theorem is correct)
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

Hawk

Quote from: Napalm Nick on May 23, 2015, 10:41:34 AM
And I would of lost my money

all compared and correct - the only one I don't compare is the VARESE.

Now, this isn't in the BikeMod because it is a STANDARD bike - so is it a case of you have extracted the VARESE? Hence Mis-match ????

;D

I used to many moons ago, but now I don't extract the default bikes at all(Lesson learned from dibu.  ;) ).

All I do is create default bike folders with the paint folder in each one so that different paints can be installed for the default bikes.

Just finished installing the BikeMOD.zip compilation..... Testing now.  ;)

Hawk.

Hawk

As I suspected. After installing the BikeMOD.zip 2.90 version I have no problems connecting at all. This surely means that there must be differences between the BikeMod no paints loose files and the BikeMOD.zip compilation?

Hawk.

HornetMaX

Welcome to the world of "It's always a mess to have two repositories instead of a single one".

MaX.

Napalm Nick

Agreed. If I get time I will download all the loose files and do a comparison pffff
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

BOBR6 84

just a thought.. would it be better to add and download just the new content? instead of the whole package each time?

have a base package download for newcomers.. bikemod 2.90 with everything there, then just add to it after that..

Napalm Nick

That is what happens Bob.

the BikeMod.zip gives everything, should someone want it.

The No paints Bikemod contains individual files to pick and choose. Klax announces new files - people go to No Paints and downloads the new stuff, Klax makes a new BikeMod.zip should someone want it. The routine is sound, its just keeping 3 areas in sync.

IMO the FTP and Mega BikeMod.zip are usually equal.  The No Paints area sometimes has differences. 

I am about to compare all the files ......stand by!
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

Napalm Nick

well I would do but the Ducati GP10v1.2 and Speed Up  zips in the No paints folder refuse to download with an error!

Anyone else get this?

Comparing the rest now...
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

Napalm Nick

OK the results are in - with the exception of the Duke and Speed Up which I still cant download:

15:43:25 \piaggio_zip_sp\d_rr125_07_f_soft.tyre 
15:43:25 \piaggio_zip_sp\d_rr125_07_f_ssoft.tyre 
15:43:25 \piaggio_zip_sp\d_rr125_07_r_soft.tyre
15:43:25 \piaggio_zip_sp\d_rr125_07_r_ssoft.tyre
15:43:25 \piaggio_zip_sp\piaggio_zip.geom 
15:43:25 \piaggio_zip_sp\piaggio_zip_sp.cfg 

There is a difference between NOPAINTS and ZIP with this whole bike. I don't know which is the newer but this would explain mis-matches as far as I can see? (critical geo and cfg files).

Schwing....hope it can be sorted easily this is too much work to be wasted  ::)
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

PeterV

Quote from: Napalm Nick on May 23, 2015, 02:48:55 PM
OK the results are in - with the exception of the Duke and Speed Up which I still cant download:

15:43:25 \piaggio_zip_sp\d_rr125_07_f_soft.tyre 
15:43:25 \piaggio_zip_sp\d_rr125_07_f_ssoft.tyre 
15:43:25 \piaggio_zip_sp\d_rr125_07_r_soft.tyre
15:43:25 \piaggio_zip_sp\d_rr125_07_r_ssoft.tyre
15:43:25 \piaggio_zip_sp\piaggio_zip.geom 
15:43:25 \piaggio_zip_sp\piaggio_zip_sp.cfg 

There is a difference between NOPAINTS and ZIP with this whole bike. I don't know which is the newer but this would explain mis-matches as far as I can see? (critical geo and cfg files).

Schwing....hope it can be sorted easily this is too much work to be wasted  ::)

Quote from: PeterV on May 16, 2015, 02:27:22 PM
oke tested again with timestamp off and now it only shows piaggio_zip errors

Like i already mentioned before  ;)

Hawk

Then the auto sync is not verifying files it uploads, as it sounds to me that files are sometimes being corrupted during upload to the database?

Hawk.

Napalm Nick

It is possible. But there are creation dates and file size differences that make me think maybe not this time. Anything is possibles of course.  ::)
"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"