• Welcome to PiBoSo Official Forum. Please login or sign up.
 
September 25, 2020, 07:45:12 AM

News:

World Racing Series beta14 available! :)


MaxHUD plugin

Started by HornetMaX, September 26, 2013, 04:34:50 PM

Previous topic - Next topic

LOOPATELI

Max, but don't you think that the stereo is too much? I mean:
Fritas person view, you lean right and all the sound goes to the left speaker,you can't hear anything from the right speaker (or headphones): I think this is way too much, and it feels so weird.

The same happens with some of the replay cameras.

I think the sound has to be a little more "mono", don't know how to explain it in english

HornetMaX

Quote from: LOOPATELI on January 05, 2016, 10:30:07 AM
Max, but don't you think that the stereo is too much? I mean:
Fritas person view, you lean right and all the sound goes to the left speaker,you can't hear anything from the right speaker (or headphones): I think this is way too much, and it feels so weird.
Doesn't happen for me: 1st person view, lean right --> I still have sound on both channels, not only on right (or left) channel.

Quote from: LOOPATELI on January 05, 2016, 10:30:07 AM
The same happens with some of the replay cameras.
What do you mean exactly ? let's say you have a camera trackside on the finish line at victoria, pointed along the finish line (so looking at the pits).
If the camera is not moving (nor rotating), bikes comes from the left: it's normal to hear a louder sound on the left channel first, and then louder on the right channel after.

LOOPATELI

Ok so I have a problem with my sound engine, maybe a fresh reinstall? Don't think so because this happen to me since I arrived in beta 4. maybe the pc's hardware...

but yeah when i lean i have all the sound in one channel and nothing in the other, it's too drastic. Same happen as I said in replays (on board cameras and TV cameras and so)

HornetMaX

Quote from: LOOPATELI on January 05, 2016, 11:00:05 AM
Ok so I have a problem with my sound engine, maybe a fresh reinstall? Don't think so because this happen to me since I arrived in beta 4. maybe the pc's hardware...

but yeah when i lean i have all the sound in one channel and nothing in the other, it's too drastic. Same happen as I said in replays (on board cameras and TV cameras and so)
If you you record a video while playing (or while watching a replay), watching the video do you have the same problem (audio only on one channel) ?
If yes, upload the video somewhere and let me know.
If you upload on youtube, watch it on youtube to confirm you only hear audio from one channel even in youtube.

Stout Johnson

Quote from: LOOPATELI on January 05, 2016, 11:00:05 AM
Ok so I have a problem with my sound engine, maybe a fresh reinstall? Don't think so because this happen to me since I arrived in beta 4. maybe the pc's hardware...

but yeah when i lean i have all the sound in one channel and nothing in the other, it's too drastic. Same happen as I said in replays (on board cameras and TV cameras and so)
I have to double check when I am at home, but I was also under the impression that when leaning only one channel is played. That's why I said the sound engine in GPB was very rough.
    -----------   WarStout Kawasaki Team   -----------

HornetMaX

That makes 3 with the same problem/impression. Worth a dedicated post because if it is confirmed, it sounds like a bug or something wrong between GPB/OpenAL and your hardware.


Meyer#12

Quote from: HornetMaX on January 03, 2016, 12:02:56 AM
GPB reinstall on top of existing install is almost free (I think you only lose the custom settings in core.ini, if any).

First got time to test now, but the reinstall on top fixed my MaxHud problem, thanks a lot!
Meyer#12

tseklias

Quote from: HornetMaX on January 05, 2016, 10:07:14 AM
I think you don't understand what mono means. Mono/stereo has nothing to do with the number of "separate" sound sources.
Your brain hears a stereo sound always, because you have two ears, no matter if the sound is emitted by a single loudspeaker (hence a "mono" sound), a headset with separate left and right channels (so potentially a stereo sound) or a 7.1 system.

GPB has mono sounds for everything (engine, transmission, knee sliders etc): virtually they are "emitted" in the virtual 3d space and "recorder" by two "virtual ears" (listeners) and this generates the stereo sound that you hear in your headset/speakers.

No, i actually don't but from your explanation wasn't hard to understand. Thanks Max.

Quote from: LOOPATELI on January 05, 2016, 10:30:07 AM
Fritas person view, you lean right and all the sound goes to the left speaker,you can't hear anything from the right speaker (or headphones): I think this is way too much, and it feels so weird.

I have the same "problem". Thought that wasn't a problem actually(that this was intentionally for somewhat reason that way made) but since it's mentioned i can tell you that at all 3 pcs i have changed so far, it worked this way. One side is deaf when leaning.

HornetMaX

OK, let's discuss the sound issue (that is not related to MaxHUD) in the dedicated topic created by LOOPA: http://forum.piboso.com/index.php?topic=3031.msg46887#msg46887

@Meyer#12: glad you solved your problem. In my experience, from time to time something goes really wrong in GPB an a re-install (on-top) really helps.

Klax75

Hey, I noticed something, with the new widget for the thumb stick inputs it also has throttle and brake on it. But in that widget throttle is listed as red, and brake green. Where as the other widget for throttle, brake, rear brake, and clutch. Throttle is green and brake is red. :)

HornetMaX

Quote from: Klax75 on February 09, 2016, 11:06:00 AM
Hey, I noticed something, with the new widget for the thumb stick inputs it also has throttle and brake on it. But in that widget throttle is listed as red, and brake green. Where as the other widget for throttle, brake, rear brake, and clutch. Throttle is green and brake is red. :)
That widget doesn't know what's brake and what's throttle, it only knows about left trigger and right trigger (plus left/right joystick).
I may want to change the colors though, just to avoid the confusion.

r1rossi


Napalm Nick

"The post you are writing has been written at least ten times already in the last 15ish years. Its already been reported, suggested, discussed, ignored or archived (but mostly ignored). Why are you doing it again?"

HornetMaX

It works for beta8 (by chance, but it works).

Hawk

Quote from: HornetMaX on February 18, 2016, 08:46:31 PM
It works for beta8 (by chance, but it works).

I was wondering if we needed any update for this but apparently not.... That is great news! ;D

Don't know what we'd do without this plugin of yours, Max, it's become an essential add-on. Thanks Max!  ;D 8)

Hawk.