• Welcome to PiBoSo Official Forum. Please login or sign up.
 
July 03, 2020, 10:30:45 AM

News:

World Racing Series beta14 available! :)


animated objects and shaders - ESCALATED

Started by h106frp, March 02, 2020, 12:40:14 AM

Previous topic - Next topic

h106frp

March 02, 2020, 12:40:14 AM Last Edit: March 08, 2020, 09:08:41 AM by h106frp
After a lot of trial end error I have a working animated shock but I do not appear to be able to apply any working shaders. Tried a basic value call and a full map without any success. THe same texture will shade OK if its not animated.
The texture also appears quite dark in game but looks OK on the shock refernce image in bikeED


h106frp

A bit more trial and error and some results;
Using identical files for model and textures.

1. Compiling with latest standalone fbx2edf_x64 and shaders are corrupt
2. Compiling with 3dsMax 64 bit plugin and shaders are OK

It appears the issue is the current fbx2edf.

doubledragoncc

You are the man!!! Love your work.

Thank you and I hope you make another bike. Your Duke is the best model ever made. No disrespect to others but it is so good. Thanks

DD
GPBOC Live Streams: https://www.youtube.com/c/IASystemsComputerControls; i7 7700 4.8GHz z270 ASUS Maximus Code Mobo 16GB 3866MHz DDR4 RAM ASUS Strix RTX2070 OC 8GB DDR6 Kraken X62 AIO Cooler ROG Thor 850w PSU in ROG Helios Tower Case.
https://paypal.me/IASystems

iNsane

March 04, 2020, 11:20:57 AM #3 Last Edit: March 05, 2020, 11:22:28 AM by iNsane
Actually happy I'm not alone with that problem. I tried it with fbx2edf version 1.22-1.25 and it seems that since 1.22 this problem exists.

This is with using a .shd file:


This is without using a .shd file:


I compared it with previous imports I've done with older versions where animations are textured without any problems, I think it was 1.21 and after that the normals fix has been implemented. Wasn't able to find a copy of 1.21 but I'll have to dig deeper on my disks.

Just don't want to use older versions than 1.25 as there have been good fixes until date, and the normals fix is quite important.

I've also reported this to Pibs via DM. Still waiting for an actual investigation of the problem. Pauses my next MX Bikes bike imports a bit.

Edit:
This is an older model imported with an older fbx2edf version, I thought it was 1.22 as I've found that in my tools folder, but currently I believe it was 1.21


Edit2:
I just found this old thread where it was about wrong shaders: https://forum.piboso.com/index.php?topic=7537.msg101503#msg101503
There's a download link to 1.20 and as I stated there, the normals have been messed up after that, so >1.20 there were problems with normals (guess it was really the initiated normals fix) and Pibs simply didn't noticed, that shapeanim meshes are still messed up.


Edit3:
Converted the model with fbx2edf 1.20 with animations and shader.

h106frp

If the captions for the first two images are revrsed then I obsrve the same  the .shd causes the animated part to display as black. Nice to know it is all repeatable.
I really do not want to revert to an older fbx2edf either, I guess the max plugin is a work around or wait for a fix.

Thanks for the feedback, very nice bike model by the way.

iNsane

March 05, 2020, 05:43:15 AM #5 Last Edit: March 05, 2020, 11:22:09 AM by iNsane
* Tools: fixed the fbx2edf calculation of normals of shape animated objects

I think we'll get an update today or so :)

Oh btw
Quote from: h106frp on March 04, 2020, 04:46:28 PMIf the captions for the first two images are revrsed then I obsrve the same  the
Yes it was reversed 😫

PiBoSo

"Obviously your ambition outweighs your talent".

h106frp

Only just got around to testing but it appears the shader issue is resolved with the latest fbx2edf.

Thank you.

h106frp

It looked like the fbx2edf update was working but after updating some of the textures it appears that the fix is not very robust and I am back to the same situation and I really do not know what has caused the disfunction.

I have tried re-building my materials and texture assignments but I still have the same issues with  textures that always look OK in BikeED view but not in-game. It is noticeable that although a lot better the maxplugin does not achieve a fully faithful reproduction of the texture tones and is generally shader darker than would be expected.